barra de menu

viernes, 19 de junio de 2015

LABORATORIO CAPA 2 - CCNP

TOPOLOGÍA



ESCENARIO

Un cliente te ha llamado porque se han quedado sin acceso al servidor. Todo funcionaba correctamente hasta que se ha caído el enlace entre CORE2 y R2. Uno de los empleados que tiene conocimientos de redes ha intentado solucionarlo pero no acaba de encontrar el problema.

Hay que resolver los problemas sin conectar el enlace de CORE2 y R2.

El escenario presenta de la siguiente manera:

CORE1 es el equipo principal. Todo el tráfico entra y sale por el enlace CORE1-R1.

CORE2 solo toma posesión del servicio si R1 falla.

ASW1 Y ASW2 son switches de acceso.


Solo debemos configurar en los equipos ASW1, ASW2, CORE1 y CORE2. Los routers R1, R2 y el servidor están correctamente configurados. SW1 es un switch ethernet de los que ofrece el propio programa GNS3. Conectar el Server (es un VPC de GNS3 al que le he cambiado el icono) al puerto 7.

El PC1 es una visita temporal que necesita acceso y tiene que recibir la dirección por DHCP y llegar al servidor por ping. 

El PC2 tiene una ip fija. También tiene que llegar al servidor.

Comandos en PC:

sh ip -  para ver la ip

ip dhcp -x - para liberar de ip (release)

ip dhcp -r -  para renovar la ip

ping X.X.X.X - para comprobar comunicación 


Todos los enlaces deben quedar disponibles y funcionando. Al final del laboratorio, cuando hayamos conseguido llegar por ping al servidor, podemos restablecer el enlace entre CORE2 y R2 uniendo simplemente las interfaces e0/1 de CORE2 y R2 y, comprobar que es CORE1 el equipo que gestiona el tráfico.

Para administra las vlans tenemos que usar la antigua forma de #vlan database y show vlan-switch


Archivo con proyecto GNS3


Recordad que para que se monte el laboratorio tendréis que tener ya añadida la imagen de Cisco en las preferencias del GNS3. Descargadla y luego:

Vamos a usar GNS3.

Después a Edit - Preferences - Dynamips - IOS routers. Ahí, le damos a "New" y buscamos y añadimos la imagen de donde la hayamos guardado.

----------------------------------------------------------------------------------------------------------
.
Configuraciones inciales:


ASW1

ASW1#sh run

hostname ASW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
!

!
interface Port-channel1
 switchport trunk native vlan 30
 switchport mode trunk
!
interface Port-channel2
 switchport trunk native vlan 30
 switchport mode trunk
!
interface FastEthernet0/0
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/1
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/14
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet0/15
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 2 mode on
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0



ASW2


ASW2#sh run

hostname ASW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup

!
interface Port-channel6
 switchport trunk native vlan 30
 switchport mode trunk
!
interface FastEthernet0/0
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 6 mode on
 spanning-tree portfast
!
interface FastEthernet0/1
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 6 mode on
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport access vlan 40
 spanning-tree portfast
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan40
 ip address 192.168.40.2 255.255.255.0
!


CORE1

CORE1#sh run

hostname CORE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
monitor session 1 destination interface Fa1/10
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.10.128 192.168.10.255
!
ip dhcp pool DHCP
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   domain-name wr
!
spanning-tree vlan 10 priority 1
spanning-tree vlan 20 priority 1
spanning-tree vlan 30 priority 1
spanning-tree vlan 40 priority 1
spanning-tree vlan 50 priority 1
!
interface Port-channel1
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-14,16-1005
 switchport mode trunk
!
interface Port-channel2
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-19,26-39,50,1002-1005
 switchport mode trunk
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.252
 full-duplex
!
interface FastEthernet1/0
 switchport trunk native vlan 40
 switchport trunk allowed vlan 1-14,16-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/1
 switchport trunk native vlan 40
 switchport trunk allowed vlan 1-14,16-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/10
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-19,26-39,50,1002-1005
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/11
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-19,26-39,50,1002-1005
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/14
 switchport trunk native vlan 30
 shutdown
!
interface FastEthernet1/15
 switchport trunk native vlan 30
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.10.2 255.255.255.0
 glbp 1 ip 192.168.10.1
 glbp 1 priority 110
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
!
router eigrp 25
 network 10.0.0.0 0.0.0.3
 network 192.168.10.0
 network 192.168.40.0
 no auto-summary


CORE2

CORE2#sh run

hostname CORE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
no ip icmp rate-limit unreachable
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1 192.168.10.127
!
ip dhcp pool DHCP
   network 192.168.0.0 255.255.255.0
   domain-name wr
   default-router 192.168.0.1
!
spanning-tree vlan 10 priority 1
!
interface Port-channel2
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-9,11-1005
 switchport mode trunk
!
interface Port-channel1
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-19,21-1005
 switchport mode trunk
!
interface Port-channel6
 switchport trunk native vlan 30
 switchport mode trunk
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/1
 ip address 10.0.0.5 255.255.255.252
 full-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet1/0
 switchport trunk native vlan 30
 switchport mode trunk
 shutdown
 channel-group 6 mode on
!
interface FastEthernet1/1
 switchport trunk native vlan 30
 switchport mode trunk
 channel-group 6 mode on
!
interface FastEthernet1/10
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-9,11-1005
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/11
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-9,11-1005
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-19,21-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/15
 switchport trunk native vlan 30
 switchport trunk allowed vlan 1-19,21-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.10.3 255.255.255.0
 glbp 1 ip 192.168.10.1
!
interface Vlan40
 ip address 192.168.40.2 255.255.255.0
!
router eigrp 25
 network 10.0.0.4 0.0.0.3
 network 192.168.10.0
 network 192.168.40.0
 no auto-summary


R1

R1#sh run

interface Ethernet0/0
 ip address 172.16.10.2 255.255.255.0
 full-duplex
 glbp 1 ip 172.16.10.1
!
interface Ethernet0/1
 ip address 10.0.0.2 255.255.255.252
 full-duplex
!
router eigrp 25
 network 10.0.0.0 0.0.0.3
 network 172.16.10.0 0.0.0.255
 no auto-summary

R2

R2#sh run

interface Ethernet0/0
 ip address 172.16.10.3 255.255.255.0
 full-duplex
 glbp 1 ip 172.16.10.1
!
interface Ethernet0/1
 ip address 10.0.0.6 255.255.255.252
 ip bandwidth-percent eigrp 25 10
 full-duplex
!
router eigrp 25
 network 10.0.0.4 0.0.0.3
 network 172.16.10.0 0.0.0.255
 no auto-summary
!




No hay comentarios:

Publicar un comentario